Easy Agile Programs Jira Compatibility Support

As a small team, it’s becoming increasingly difficult to support versions of Jira that are no longer supported by Atlassian.

From the release of Easy Agile Programs v3.5.0 and onwards, we will no longer be supporting Jira 7.X. 

If you are using Jira 7.X, you can continue to use our app however you won’t be able to upgrade to the latest version.