Next-gen compatibility: Configuration A - I want to schedule epics from the selected team agile boards onto my Program Roadmap

By selecting this option, Easy Agile Programs will use the epic link to link stories to the epics on the Roadmap. Limited functionality exists for Programs where epic linking is used:

Create or edit a Program

  • (tick) Next-gen boards can be added to a new or existing program - this includes next-gen boards set up as scrum or kanban

Create an Increment

(error) A next-gen board can’t be used for global/shared sprints.

Reason - Completing a sprint that contains both classic and next-gen issues on a next-gen board will not roll classic issues into the next sprint.

(error) When creating a new increment, you won’t be able to select a next-gen board for shared sprints. This is because completing a sprint that contains both classic and next-gen issues on a next-gen board will not roll classic issues into the next sprint.

Please be aware that shared sprints (from a classic board) will not appear on the next-gen board. Any issues allocated to a shared classic sprint will appear in the next-gen backlog.

(error) Next-gen kanban boards are not compatible with shared sprints. Currently, we’re unable to support next-gen kanban boards when using global sprints as this is not supported by Jira.

Increment Roadmap

  • (tick) Classic epics (features) can be scheduled into the next-gen and shared team swimlanes

  • (error) Next-gen epics won’t be shown in the roadmap backlog as they can’t be scheduled on the roadmap

Reason - Jira doesn't classify classic and next-gen epics in the same way and epic linking is not possible between a next-gen epic and a classic issue.

Team Planning Board

  • (tick) Classic epics (features) scheduled into the next-gen and shared team swimlanes will be shown on the next-gen team planning board

  • (tick) Next-gen issues will be shown on the backlog and can be scheduled into the increment sprints

  • (tick) Dependencies can be created and viewed between next-gen and classic issues

  • (warning) You won’t be able to filter issues by clicking on a feature

  • (warning) You won’t be able to click on classic epic to create new issues linked to that epic. This is because epic linking is not possible between a classic epic and a next-gen issue.